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MY SIGN NOTES

PHYSICAL PIXEL MATRIX:   __________X____________

The physical pixel matrix of the sign (i.e. 48 pixels high X 96 pixels wide)

VIRTUAL PIXEL MATRIX:   __________X___________

Use only if applicable. This size will be double the Physical Pixel Matrix and will be 
the optimum size for custom created content (i.e. 96 X 192)

SIGN IP (NETWORK) ADDRESS: _____ . _____ . _____ . _____

OTHER NOTES:

INSTALLATION

Note: LightSpeed requires Windows XP, Vista, or Windows 7

1. Insert the CD into your computer’s CD Rom.

2. Click SignScheduler on the main install screen and follow the prompts to 
install the software to your computer. 

3. The Installation Screen should appear automatically. If it does not, navi-
gate directly to the CD and double click on Setup.exe. 
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OVERVIEW

LightSpeed provides a single interface for operating your sign, allowing you to 
quickly view, edit, and add content to your sign. The software sends the entire 
schedule, along with the messages and any linked media files to the sign each time 
you transmit or Send. This allows the sign to playback the schedule on its own, 
until you re-transmit updated content at your convenience. 

To open, click on the SignScheduler Icon on your desktop.

All of  your sign related tasks start here, including:

- Setup Communications and other options.

- Add, Modify and Remove individual messages.

- Copy and Paste entire messages with linked attributes to aid in template creation 
or repeating messages. 

- View entire Schedule including Dates, Times, Days of week, Media, Play Duration, 
and Play Count. 

- Preview individual messages, or the entire schedule list.

- Send/Transmit Content to the sign. 

SETUP OPTIONS

Communications

After installation, you will need to configure the communication options in the 
software. Your computer’s IP address must be on the same network scheme as the 
sign or communications will fail.  If you need help setting your IP address, or have 
a custom communication option please contact your network administrator or our 
technical support dept. 

1. Go to the Tools menu and select Options. This will open the Options 
window. 

2. Select the Connection>Protocol section. 

3. Choose TCP/IP from the options presented, and enter the IP address of 
the sign.  Do not change the Port unless specifically asked to do so. The 
default setting is 6952.

4. Next, set the Brightness Schedule in the following section.
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Brightness Schedule

To achieve readability at night the software provides a Brightness Schedule option. 
This will dim your display at the specified times to keep in line with local codes, 
and improve readability.  Typical brightness levels are 60-70% at night, and 100% 
during the day. 

1. Still in the Options window, select the Brightness option. 

2. You can set the brightness level for every hour of the day and night from 
0% (blank sign) to %100 (full brightness). 

3. Select the desired hour to adjust, and press the Edit button. Note: You 
can select multiple time slots by holding the Shift or CTRL key while 
selecting the hours.

4. When finished press the OK button. 

5. This will bring you back to the Options window. When you have set the 
desired brightness schedule, press the OK Button to save the changes. 

Note: The Brightness Schedule will be sent to the sign when you transmit 
your messages. 
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MESSAGE CREATION

There are (2) types of messages you can add to the schedule:

Pre-Created Media Files:  Includes Image Files ( JPG, GIF, BMP) and Movie/Anima-
tion files (SWF, AVI, MPG, WMV, MOV, Animated GIF)

QuickEdit Messages: Custom messages created using the sign software. 

PRE-CREATED MEDIA:

1. Click on the Add  button. This will bring up the  Add Schedule Entry 
window. 

2. Select Media File then press the Browse button. 

3. Navigate to the file you would like to add, and press Open.

4. Select the Play Duration of the media file. Note: for static images you 
must set a time. Video and animations will automatically play full length.

 

5. Select your desired Play Count (only valid if using a video). This lets you 
to repeat the Video/Animation multiple times. 

6. Now select the Date/Time tab at the top of the window and choose your 
desired scheduling options:

Start Date: When your message will start

End Date: When your message will end

Start Time: When your message will 
begin playing each day

End Time: When your message will stop 
playing each day

Day of Week: When your message will 
play during the week.
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7. When you are finished, press the OK button. 

8. This brings you back to the main SignScheduler interface. You can now 
see a summary of your message details listed here. To edit the message, 
you can double click, or select it and press the Edit button. 

9. To add more Pre-Created Media, repeat the previous steps. 

QUICK EDIT MESSAGE:

1. Click on the Add button. This will bring up the Add Schedule Entry win-
dow. 

2. Select QuickEdit Message then press the Create button. 

3. This opens the QuickEdit Message Editor. 

Note: The large black box represents the LED sign.  
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 ADD TEXT

1. To add text, go to the Insert menu, and select Text. Then click on the 
large black box. 

2. To edit the text, type into the small white box titled Simple Text. 

3. Arrange the text on your sign by using your mouse to drag the text to the 
desired location. You can also Right Click and choose the Move To menu 
for an exact location on the screen.

 

4. Adjust the font size, color and other effects by selecting Font from the 
Format menu above. This opens the QuickEdit Font window. 

5. After choosing the desired font options, press the OK button. 



 12  13

ADD EFFECTS TO TEXT

1. Click on the text you would like to add the effects to.

2. Go to the Format Menu and select Effect. This opens the QuickEdit Text 
Effect window.  Set your options as needed. 

• Start Time: Use to delay the text from appearing on the screen.

• Enter Effect: The effect used when the text enters the screen. 

• Hold Duration:  Time to hold text, before going to the Exit Effect

• Exit Effect: The type of effect used when the text exits the screen. 

• Hold Duration before After Effect: The time to hold the text on the 
screen after the Exit effect is completed. 

• After Effect: What to do with the text after all effects are complete

• Repeat Effect: Repeat the effect until the entire message is done

• Stay at Hold Point: Keep the text on the screen without any effect

• Hide Text: Hide the text after all the effects are completed. 

3. You can preview the message and effect at any time by pressing the 
Preview Button. 

4. When you are finished, press the OK button. 

5. To add more text, repeat the previous steps.
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ADD MEDIA (Images, Animations, Video)

You can add pre-created media inside the QuickEdit message directly. 

1. Go to the Insert menu  and select Media

2. Navigate to the media you would like to insert, and press the Open but-
ton. 

3. Now click on the black area to place the media on the screen. 

4. You can adjust the size of the media by pulling the anchor points with 
your mouse, or right click on the media and selecting the Re-Size menu. 

5. To add more media, repeat the previous steps. 
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TO ADD TIME, DATE, or TEMPERATURE

The Time, Date, and Temperature are inserted into the message as separate ob-
jects. You can add them to any QuickEdit Message. 

1. Go to the Insert menu and select Time, then click on the black area to 
insert the time on the screen. 

2. Adjust the Font and Effects as described earlier in the ADD TEXT and 
ADD EFFECTS section.

3. Press OK to bring you back to the main editor, and move the time to 
the desired location. 

4. To add Date and Temperature, repeat the previous steps and select 
the desired object to insert (Date, Temperature). 
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ARRANGING and MANIPULATING OBJECTS

You can arrange the order of any object (Text, Image, Time, etc…) by using the Ob-
ject Viewer Window, shown here on the right side of the editor. If you do not see 
this window, you can enable it by selecting the View menu, and selecting Object 
Viewer. 

1. Select the object you wish to manipulate. 

2. Click on the appropriate action button:

a. Copy

b. Paste

c. Delete

d. Move UP

e. Move DOWN

3. To manipulate another object, just select it in the object list and press 
the appropriate action button. 

QUICK EDIT SAVING and COMPLETION

1. When you are finished with your QuickEdit message, remember to Name 
it using the Message Name field. Make sure you use a descriptive name 
for quick reference. 

2. When you have named the file, press the OK button to save the changes. 
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3. You are now at the Schedule Entry window. Select the Play Duration, 
then Preview the message by selecting the Preview button.

4. Make any adjustments as needed by selecting the Edit Button.   

Note: If the message plays too long or too short, make sure to balance the 
Effect times inside the message, with the Play Duration time on the Schedule 
Entry window. 

5. Select the Date/Time tab and Edit the scheduling options as required. 
Then press OK to save the message into the schedule.

VERIFY, PREVIEW and SENDING MESSAGES

When you are finished editing and adding messages to your schedule, you should 
always verify and preview the schedule before sending them to the sign.  

VERIFY:

Take a quick look through your messages and make sure they are scheduled to play 
at the correct time and dates.

 

LightSpeed provides quick verification by using icons:

   Ready:  The message is currently scheduled to play now. 

   Will Play:  The message is scheduled play in the future.

   Expired:  The message schedule has expired, and it will not play. 
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PREVIEW

To see a preview of your messages to make sure they will play correctly when sent 
to the sign:

1. Go to the Tools menu, and select Preview All or Preview Item.

  Preview All: Previews the entire schedule.

Preview Item: Previews only the selected item.

    

“Ready” entries: Messages currently scheduled to play now.

“Ready and “Will Play” entries: Includes future messages. 

“All” entries: Includes expired messages. 

SEND / TRANSMIT

When you are satisfied with your schedule and messages, you can send them to 
the sign. When you transmit, the software sends all the messages, media files, and 
schedule data to the sign, overwriting any previous schedule.

Note:  Remember to transmit to the sign every time you add, delete, or change a 
message. 

1. Press the Send button on the main SignScheduler window.

 

2. You will receive a confirmation if the transmission was successful. 

3. If you receive an error, please make sure your computer is connected to 
the sign using the appropriate hardware, and that the IP address of your 
computer is on the same network as the sign. If you still have transmis-
sion issues please contact technical support. 
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APPENDIX

COMMUNICATION OPTIONS (See Sign Installation Guide for More Details)
The LED sign controller holds an IP address on a network. You can communicate to the 
computer using a variety of hardware, but the fundamental communication is done using a 
standard TCP/IP network. Some typical communications options are below:

Wireless Radio Pair:

 

Wireless Radio Pair over a network:

Wireless Radio WiFi:

Wired Direct:

Wired through a Network:

IP ADDRESS (IP v4) 

The sign controller has an IP address just like any computer on a network. In order 
to communicate, your computer MUST be on the same network as the sign, and 
have an IP address that is on the same IP scheme. For example: 

Sign IP: 192.168.0.2 

Computer IP: 192.168.0.26

CHANGE IP ADDRESS (IPv4)

Warning: DO NOT change your IP address without your Network Administrator’s 
permission. You may lose connectivity to your network if you change your IP ad-
dress incorrectly. These instructions carry no guarantee, and no liability. If you are 
unsure, please call your Network Admin, or our Technical Support. 

1. Go to the Windows Start  menu and select Control Panel

2. Type adapter in the search box, then select View Network Connections. 

 Note: If you are using an earlier version of windows, just click on the Net-
work Connections icon in the control panel.
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3. Double-Click on the network connection that you will use to connect to the 
sign. 

4. Double-Click on Internet Protocol Version 4

  

5. Write down, or take a desktop screenshot of ALL the current settings in this 
window, so you can revert back to it later if needed.  

Note: To create a desktop screenshot press CTRL + PRT SC  on your keyboard. 
Then open Microsoft Paint and press CTRL+V on your keyboard to paste the 
screenshot into Paint. Then save it as a JPG or BMP to your desktop for refer-
ence. 

6. Select Use the following IP address and enter an IP address that is on the 
same scheme as the sign. Remember the last numbers must be different 
than the sign. 

7. Press the TAB key on your keyboard. This should autofill the Subnet Mask

8. Set your Default Gateway . This is not required to connect to the sign, but is 
required if you want to connect to the internet through your network. 

9. Set your DNS Servers. These are not required to connect to the sign, but are 
required if you want to connect to the internet through your network. 

10. When you are finished, press OK

11. Then press OK on the next screen. This will implement the changes.

NOTE: YOU CAN ALSO CHANGE THE IP ADDRESS OF THE SIGN TO MATCH YOUR 
NETWORK. DO NOT DO THIS WITHOUT CONSULTING YOUR NETWORK ADMIN. 
SEE THE “DATE/TIME ADJUSTMENT” SECTION OF THIS MANUAL TO GAIN ACCESS 
TO THE SIGN CONTROLLER DIRECTLY. 

Note: Make sure this IP address is 
not being used by another com-
puter on the network. If you have 
any questions, ask your Network 
Admin. 

DO NOT use the following: 
192.168.0.1
192.168.0.2
192.168.0.20
192.168.0.21
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DATE/TIME ADJUSTMENT 

You may need to set or adjust the time to show correctly on your display according 
to your location. This is accomplished by logging directly onto the sign controller 
using VNC. If you have any questions, please contact  technical support. 

1. Install and run VNC on your computer from the LightSpeed software disc.  
Note: When asked, install the “Viewer” only. 

       

2. Open VNC and type the IP address of the sign (ex: 192.168.0.2) and press the 
Connect Button. The Password can be obtained by calling your sign provider 
or techsupport. 

3. This will now show the desktop of the sign’s PC controller. Navigate to the 
lower right portion of the desktop, and Right-Click on the time. Select Adjust 
Date/Time

COMMUNICATION  PING  TEST

You can quickly verify your IP address, and communication to the sign using a 
PING test.

1. Click the Windows Start menu.  

2. In the Search box type cmd then press ENTER. This will bring up a com-
mand window. 

3. Type the word ping

4. Hit the spacebar then type in the IP address of the sign I.E.: 192.168.0.2

5. Press ENTER.

6. If you see Request timed out or Destination host unreachable then you 
will need to verify your computers IP address and any communications 
hardware. 

7. If you do get a response, then you are in low level communication with 
the sign. 

Note: If you can PING the sign, but still have trouble transmitting mes-
sages, it is usually caused by a firewall, or mis-configuration of your 
network settings. Call your Network Admin, or Tech Support. 

Note: To check your IP address, type ipconfig in the cmd window, and 
press enter. This will list all your active network adapters, and their cor-
responding IP info. 
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8. Verify your Sign Messages are playing in the top left corner of the screen.  
Then close the VNC window. 

FOR MORE INFORMATION PLEASE REFERENCE THE INSTALLATION GUIDE 
and  HELP MENU IN THE SOFTWARE.

IF YOU HAVE ANY ADDITIONAL QUESTIONS, PLEASE CONTACT YOUR SIGN 
PROVIDER OR TECHNICAL SUPPORT 888-595-3956.

4. Adjust the Time Zone, Date and Time as desired, and press OK.

5. Verify the time is correct on the lower right corner of the screen. 

6. RIGHT-CLICK on the Sign Playback program on the windows task bar, and 
select Close Window.

7. Re-open Sign Playback by Double-Clicking on the Sign Playback Icon on the 
desktop.




